[solved] Disabling the BlendLocationTerrainJob

Discuss modding questions and implementation details.
User avatar
Hazelnut
Posts: 2501
Joined: Sat Aug 26, 2017 2:46 pm
Contact:

Re: [solved] Disabling the BlendLocationTerrainJob

Post by Hazelnut »

Hmm, are you running your mod as a virtual mod? You should see compilation errors that you have to fix before you run the game in unity editor.

Anyway, no rush now as it's been merged into master so it will be in the next release. I just thought it'd be good to get you to check it first in case there was some issue. :)
See my mod code for examples of how to change various aspects of DFU: https://github.com/ajrb/dfunity-mods

monobelisk
Posts: 57
Joined: Tue Aug 25, 2020 10:43 am

Re: [solved] Disabling the BlendLocationTerrainJob

Post by monobelisk »

Hazelnut wrote: Wed Sep 16, 2020 4:21 pm Hmm, are you running your mod as a virtual mod? You should see compilation errors that you have to fix before you run the game in unity editor.
That's the weird part, opening the latest commit in Unity 2019.4.2f1 didn't produce one single error, neither did adding the Interesting Terrains mod files. No errors until I hit play and start the game from the startup menu. Mod builds just fine (except there's an error related to the Linux build), so I suppose I could test it as a non-virtual mod. Game builds fine too, just doesn't work when running it. I do use the free license, but I can't see how that could be the issue.
Hazelnut wrote: Wed Sep 16, 2020 4:21 pm Anyway, no rush now as it's been merged into master so it will be in the next release. I just thought it'd be good to get you to check it first in case there was some issue. :)
Ah, good. It's a rather simple tweak, so I'm sure it works fine - as long as the blendLocation job doesn't run, that's all I need :)


Update: I was able to load the dfmod file I built in Unity 2019.4.2f1 in the editor, overriding the virtual mod, and everything works. I can confirm that the disable location blending feature works exactly as expected :D

Post Reply