Windows #44: No inventory items for Redguard female

Report specific bugs in Daggerfall Unity. Please read guidelines before posting.
R.D.
Posts: 28
Joined: Fri Oct 07, 2016 10:41 am

Windows #44: No inventory items for Redguard female

Postby R.D. » Thu Oct 13, 2016 6:27 am

See the attached Daggerfall save. When you import this save into Daggerfall Unity, none of the items in inventory can be seen or accessed, and any equipment on the paper doll that you unequip will "disappear" as it goes to the inaccessible/nonexistent inventory. Also, if you re-save as a Daggerfall Unity save game, even the equipment on the paper doll will be lost.

This happens when running on the latest commit (355ebfa) or before the latest changes (028f889). It also happens with the latest live build (44).
Attachments
SAVE2.zip
(38.21 KiB) Downloaded 10 times
User avatar
Interkarma
Posts: 1064
Joined: Sun Mar 22, 2015 1:51 am

Re: Windows #44: No inventory items for Redguard female

Postby Interkarma » Fri Oct 14, 2016 10:48 pm

Have made a first pass at this one. It seems all items for this character are being sorted into Wagon on import (open up wagon and all 14 items are there, even equipped items). When unequipping an item it seems to vanish, but it's just unlinking the wagon item from paper doll, a state that isn't normally possible. You can move items out of wagon and equip them as normal from there.

This isn't to do with character itself - rather the container record source items are found in classic save. Previous research has shown that when first byte of certain unknown container data is 150, it seems to indicate a wagon container. This is the first instance I've come across where that is not correct, but I've always been a bit suspect on observation which is why I've left that data as "unknown". :)

So core bug here is really "items improperly sorted into wagon". More research into properly identifying wagon container record is obviously needed.
R.D.
Posts: 28
Joined: Fri Oct 07, 2016 10:41 am

Re: Windows #44: No inventory items for Redguard female

Postby R.D. » Sat Oct 15, 2016 11:40 am

As a test I made a new Redguard female character, saved immediately at the start of the game, and imported the save into Unity, but this time the inventory imported fine. So, it looks like the fact that the character this happened with was a Redguard female actually might not be relevant.

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest