KoW - D.R.E.A.M.

A curated forum for compatible and maintained mods. Users are unable to create new topics in this forum but can reply to existing topics. Please message a moderator to have your mod moved into this forum area.
Post Reply
User avatar
King of Worms
Posts: 3745
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: KoW - D.R.E.A.M.

Post by King of Worms »

Hi. Is that u who reported similar issue with orcish dagger on nexus?

I was not able to recreate that bug. I told the guy and he said the bug is gone for him as well.

Can u restart your pc and confirm the bug persist?

This is strange nevertheless. Thanks 4 report!

Taryl
Posts: 7
Joined: Tue Dec 08, 2020 10:12 pm

Re: KoW - D.R.E.A.M.

Post by Taryl »

Not me about the dagger.

I just restarted the game again cold and the issue with the broadsword persists. However, I spawned an Orcish dagger, shortsword, and then another broadsword through the console, and all of those appear correctly, even though the original broadsword still does not.

There is another issue, which I didn't mention because this looked like an art asset missing. Looting orcs, especially Warlords, has been screwy sometimes with DREAM and Realistic Roleplay both loaded. It can cause strange issues with not being able to use the UI during looting, and persistent issues with player inventory after looting from the bugged orc. I've just put that down to mod conflict. Maybe both are trying to assign loot to the same orc and it doesn't jive. I always reload and avoid looting the specific orcs with the issue. Maybe this broadsword thing is from the same cause, since it was looted from an Orc (though not a Warlord). Maybe it's just Realistic Roleplay alone and not DREAM at all. I should test that as well.

I didn't want to send you down a rabbit hole after a mod conflict, and I still don't. Since the art is there, it looks like DREAM is clean. Cheers.

User avatar
King of Worms
Posts: 3745
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: KoW - D.R.E.A.M.

Post by King of Worms »

Damn... well this honestly sounds like a issue of the roleplay mod. All my mod is doing is replacing low res with high res.

If u have the save with the bugged sword, it would be cool if u can upload it here pls.

Can u try it with other mods disabled so we are surr which mod is causing it?

I have no idea whats going on :/

But certainly the fix will be either by some DFU core adjustment or other mod fix. I cant do jack about it; I just provide the textures. But I can try to make these things happen

Taryl
Posts: 7
Joined: Tue Dec 08, 2020 10:12 pm

Re: KoW - D.R.E.A.M.

Post by Taryl »

A save with the weapon in inventory attached. It's in the third slot.

I must have gotten confused with the word 'replacement' about what each mod does exactly. When I find another bugged orc, I'll take it up with Roleplay then.
Attachments
SAVE0.zip
(416.6 KiB) Downloaded 11 times

Tomash
Posts: 2
Joined: Mon Dec 14, 2020 3:41 pm

Re: KoW - D.R.E.A.M.

Post by Tomash »

Hello,

first post here. DF Unity is awesome. DREAM makes it even more awesome.

I stumbled upon a funny bug. While everything works fine on Windows on my gaming PC (Ryzen 2700X, GTX1070), DREAM on my Linux laptop (Ryzen 4700U with amdgpu drivers) has super-dark and weirdly lit textures. It's just the textures, if I disable textures part of DREAM it's all good again, although with low-res textures. All the other componens of the mod look and work perfectly.

I put the screenshots here: https://www.dropbox.com/sh/ukpp25ppq0cb ... lTf7a?dl=0
The last two show that everything looks good again after disabling textures component.

User avatar
King of Worms
Posts: 3745
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: KoW - D.R.E.A.M.

Post by King of Worms »

Hi, thanks for taking you time to make a account and post here, welcome to the forums :)

This issue on Linux is something I saw in the past in a bug report...
Its not a problem of the mod as far as I know, but its either sub par graphics card, some SW issues or you dont use Linux version of DREAM.

Unfortunatelly, I cant solve this for you, I dont have linux, and even if I had, its not something on my side.

EDIT: Found that post! Have a look http://forums.dfworkshop.net/viewtopic. ... 5fb#p50936

He said that "after a kernel and driver update almost all the issues disappeared"

User avatar
King of Worms
Posts: 3745
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: KoW - D.R.E.A.M.

Post by King of Worms »

Help pls :)

I got a Nexus user bug report where on Win 10 he cant enable DREAM - HUD and DREAM - CINEMATICS.

They stay vanilla even when they are clearly ENABLED in game (confirmed with screenshots). I went thru it with him to make sure his setup is ok, and that these DREAM mods are enabled, and no other mods are interfering etc. Still, no luck.

I got his log files, but I dont understand them much.

At the end of the player.log I saw "HUD pushed to stack.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)"

Not sure about that one..

If someone skilled could just briefly go thru the log and maybe see some issue there, I would be grateful.

Thanks a lot!
All log files .rar
(22.39 KiB) Downloaded 13 times

Tomash
Posts: 2
Joined: Mon Dec 14, 2020 3:41 pm

Re: KoW - D.R.E.A.M.

Post by Tomash »

Thanks for the swift reply!
King of Worms wrote: Thu Jan 07, 2021 5:34 pm This issue on Linux is something I saw in the past in a bug report...
Its not a problem of the mod as far as I know, but its either sub par graphics card, some SW issues or you dont use Linux version of DREAM.

Unfortunatelly, I cant solve this for you, I dont have linux, and even if I had, its not something on my side.

EDIT: Found that post! Have a look http://forums.dfworkshop.net/viewtopic. ... 5fb#p50936

He said that "after a kernel and driver update almost all the issues disappeared"
So it gets weirder but in a positive way. I've been running mainline kernel 5.9.1 with radeon for linux 20.20, after a few attempts at using newer kernel and never radeon for linux (they failed due to some changes in kernel api which blew up the compilation) I went back to this configuration. But somewhere along the way some other packages got updated, I think including Mesa, and lo and behold, DREAM textures work like a charm now!

So I'm good now but I have no idea what fixed the issue :lol:

EDIT: I'm pretty sure now that the cause of the issue was a set of outdates libraries shipped with AMD's amdgpu package, after installing it cleanly I got the artifacts again, uninstalling made my DFU+DREAM look good again.

User avatar
King of Worms
Posts: 3745
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: KoW - D.R.E.A.M.

Post by King of Worms »

Thanks for feedback Tomash (CZ?)
I updated that link with your solution, it might help other ppl with Linux laters

User avatar
King of Worms
Posts: 3745
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: KoW - D.R.E.A.M.

Post by King of Worms »

Lol I received 5usd donation on paypal for DREAM mod. I went ahead to see the transaction and saw the email. That mail suggested the sender is a senator in usa. So I searched his name and found a usa senator with same name. I opened his tab, searched for his official email and it was the one who donated to me so its confirmed.

I will not disclose his name on a gaming forums, but I can say that he is 55yo republican.

So funny, thanks sir 😊

Post Reply