Page 1 of 1

[0.11.0] Deactivated mouse cursor mod makes cursor disappear [RESOLVED 0.11.1]

Posted: Fri Jan 08, 2021 8:11 pm
by XJDHDR
Just noticed this issue but if you have a dfmod that replaces the mouse cursor installed but deactivated, the mouse cursor is invisible after you launch the game from the DFU startup config menu.

You can test this yourself by doing the following. I used DREAM's HUD & MENU module to test this.
  • Start DFU with the DREAM module installed and activated. Once it reaches the DFU startup config menu, you will see that the mouse cursor is using DREAM's version. Make sure the HUD & MENU module is activated.
  • Launch Daggerfall. Once you reach the main menu, the mouse cursor will still be DREAM's replacement.
  • Restart DFU then deactivate the HUD & MENU module. After you do so, you will notice that the game is still using DREAM's replacement cursor.
  • Launch Daggerfall. You will now see that the cursor is invisible. You can still click on things but obviously, it's difficult to know where the cursor is.
  • Exit DFU then completely uninstall the HUD & MENU module. Relauch DFU. After you do so, the game will be using the default Daggerfall cursor in the config menu.
  • Launch Daggerfall. The game will still be using the default cursor.
Finally, I took some photos of what I'm seeing. Screenshots don't capture the mouse cursor.
Spoiler!
This picture is what I see if I have DREAM's HUD & MENU module completely uninstalled:
Cursor present.jpg
Cursor present.jpg (128.17 KiB) Viewed 245 times
This picture is what happens if the module is installed but deactivated:
Cursor disappeared.jpg
Cursor disappeared.jpg (137.13 KiB) Viewed 245 times

Edit: Forgot to mention that I'm using Windows 10 x64 if that makes a difference though I suspect the issue is something in the modding API.

Re: [0.11.0] Deactivated mouse cursor mod makes cursor disappear

Posted: Fri Jan 08, 2021 10:26 pm
by 13thsyndicate
If I'm not allowed to post here, let me know and I'll delete! I actually have the opposite problem - even when DREAM is deactivated I still get the DREAM cursor in menus.

Re: [0.11.0] Deactivated mouse cursor mod makes cursor disappear

Posted: Fri Jan 08, 2021 11:49 pm
by Interkarma
Not sure on this one. I'll move to bug reports for follow up later. Cheers!

Re: [0.11.0] Deactivated mouse cursor mod makes cursor disappear

Posted: Sat Jan 09, 2021 12:52 am
by XJDHDR
13thsyndicate wrote: Fri Jan 08, 2021 10:26 pm even when DREAM is deactivated I still get the DREAM cursor in menus.
Which menus are you talking about?

Re: [0.11.0] Deactivated mouse cursor mod makes cursor disappear

Posted: Sat Jan 09, 2021 1:22 am
by 13thsyndicate
Al of them! I get DREAM cursor in the entire game after I install DREAM until the end of time even if all my mods are disabled

Re: [0.11.0] Deactivated mouse cursor mod makes cursor disappear

Posted: Sun Jan 10, 2021 5:52 pm
by King of Worms
Well this is a known issue for quite some time, I think Ive reported it as well?

Lets start from the end:
Issue 1)
IF DFU has a Mod in the mod folder, which replaces the cursor, than DISABLING the mod is not enough. U must REMOVE the mod from the folder, to get back to vanila cursor.

Issue 2)
If u just disable the mod, u can get to situation described at start (no cursor) or situation described in Issue 1 (modded cursor still present eventho mod is disabled)

To my best knowledge, this has something to do with a DFU reading all mods at runtime, no matter if enabled or not. And in this one specific case - cursor - it behaves in this strange way.

I remember it was discussed thru mails I received from git, where the whole cursor logic was remade by Pango (this is not a accusation mate :) ) - it was in times where modded cursor size was altered so my 64x64 cursor was no longer resized to 32x32 but I had to provide new 32x32 cursor so it was not 2x as big as before this change was implemented.

Thats all I know about this😊

Re: [0.11.0] Deactivated mouse cursor mod makes cursor disappear

Posted: Fri Jan 22, 2021 1:39 am
by Interkarma
TheLacus has pushed a change that should resolve this in 0.11.1.

Thankyou TheLacus! :)