Page 1 of 1

[0.11.1] Combining Teleport and Open effect into one spell makes Open effect persist with Teleport

Posted: Sat Feb 20, 2021 11:55 pm
by Shalval
After some deliberation on the Discord server and getting a confirmation that it happens on other computers, I come back with a puzzling issue...

While exploring a dungeon I realized that I could not interact with doors. At all. If they are closed, nothing happen. If they are open, I can't close them.

I (or monsters) could bash them open. Someone on Discord confirmed that using the command openalldoors worked. But clicking them doesn't register for some reason. And the save I shared didn't seem to show any useful data for why it happened.

Quoting from Discord:
Magicono43Today at 12:19 AM
Yeah, i'm not seeing any errors from the not working save
And the clicks register, since it says "you are too far away" if you click toward a far away door
But the action doors themselves won't open or close when you click them
But they work if you bash them down, or do "openalldoors" in console
Very strange
Discussing with NPCs, using the dungeon exit, clicking in menus, looting... All of that works.

I tracked back and saw that it was happening in an inn prior to my departure to the dungeon. I assume doors were still working before that save, since I must have exited a bedroom after sleeping.

Here is what I did before the first faulty save:
  • I got a quest from Knights of the Dragon
  • I went to the nearest inn and slept
  • I put an anchor inside that inn
  • I used a custom spell called "Water Crossing" twice to train my skills
  • Finally, I saved
I do not use any mod.

I attached three saves:
  • BEFORE-BUG: I'm inside Knights of the Dragon. Everything works.
  • INN-BEFORE-DUNGEON: The save after the series of actions I listed above. If you go upstairs, you will see that doors stopped working at that point.
  • DUNGEON: A later save where doors are still not working

Re: [0.11.1] Clicking actionable doors suddenly not working

Posted: Sun Feb 21, 2021 12:35 am
by Interkarma
The doors themselves are all working OK, as is the click. The core issue is that you have an Open effect active on your character, which is blocking the regular clicks looking for a locked door.

What's happened is that you've combined a Teleport and Open into a single spell, which aren't a very logical or functional pairing. This is in your spellbook called "Teleport", but it also has Open effect.

teleport_open.JPG (192.36 KiB) Viewed 92 times

So from the moment you cast your anchor, a long-running effect, you've also pinned the Open spell in place waiting for a door to unlock. This is an interesting edge case and should have some handling. I'll move this to bug reports for later followup.

In the interim, you can fix this by cancelling out your active teleport (e.g. cast Anchor again, then Teleport back to Anchor right away). After doing this on my end, doors are working again once that Teleport spell drops off.

Recommend deleting that wonky Teleport spell from spellbook and recreating. It will be a bit cheaper too without the random Open effect in the mix.

Re: [0.11.1] Combining Teleport and Open effect into one spell makes Open effect persist with Teleport

Posted: Sun Feb 21, 2021 12:39 am
by Shalval
WOW, maybe that's why this spell was costing so much :lol:

I must have changed my mind while using the spellmaker and didn't notice the abomination I just made...

Re: [0.11.1] Combining Teleport and Open effect into one spell makes Open effect persist with Teleport

Posted: Sun Feb 21, 2021 12:42 am
by Magicono43
Good find there IK, I had not thought of looking at the spell-book for some reason when I tried the save myself, lol.