[0.10.26a] Stuttering while in towns - Diagnostic tools?

Post here if you need help getting started with Daggerfall Unity or just want to clarify a potential bug. Questions about playing or modding classic Daggerfall should be posted to Community.
User avatar
KovuCougar
Posts: 36
Joined: Thu Aug 27, 2020 3:32 am

[0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by KovuCougar »

When I'm in towns I get stuttering happening every couple of seconds. (Windows 10)

It does not happen with mods disabled, which is good, but I'm using the same modset (with upgrades where available and only new ones are TravelOptions and BasicRoads instead of TediousTravel) I was using with 0.10.24 and it didn't happen there. So there's some kind of interaction that's been introduced with them since. Does not seem to happen in wilderness or dungeons, just in towns.

I've tried disabling and selectively re-enabling them, but so far have not had luck tracking it down to make a better report with. Was wondering if there's any debug or diagnostic tools that might help me help diagnose this so I can make a proper report?

User avatar
Ralzar
Posts: 1612
Joined: Mon Oct 07, 2019 4:11 pm
Location: Norway

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by Ralzar »

Are you using the new Warm Ashes? It caused a lot of stuttering in town for me.
My released mods

"I feel like Ralzar specifically wrote those mods for me and then said "Use them". Just so he could watch me die more."
-FuzzyBeanPlays

User avatar
KovuCougar
Posts: 36
Joined: Thu Aug 27, 2020 3:32 am

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by KovuCougar »

I am. I tried disabling it. It may have helped a little bit.

I also disabled all the DREAM and Hand Painted Models. That did not seem to make much difference (but it did make the mouse pointer disappear which made loading a save hard :lol:)

I'll attach a save so those interested can see my current modlist. This is a random character generated, left PH, and went to Gothway Garden to check on stuttering so is pretty close to minimal with the given modset. I just checked/refreshed/downloaded all the mods yesterday so should be current versions.

I did also install WA3 while trying something out now that I think of it, given that WA4 has not yet got a lot of the stuff ported over.
Attachments
SAVE35.zip
(613.04 KiB) Downloaded 10 times

User avatar
Interkarma
Posts: 5842
Joined: Sun Mar 22, 2015 1:51 am

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by Interkarma »

My recommendation is not to install any mod unless it specifically has compatibility with 0.10.26+.

A lot of folks seem to be carrying old mods forward from 0.10.24 and encountering various issues with performance and stability. If any of the mods you're using were downloaded prior to September 21, they likely weren't built for 0.10.26.

User avatar
KovuCougar
Posts: 36
Joined: Thu Aug 27, 2020 3:32 am

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by KovuCougar »

Ok, thanks.

I'll shelve 0.10.26 for now and continue my campaign on 0.10.24 until the next stable and hopefully by then all the others will be up-reved. Had just run into a broken quest or two that I saw were fixed in future releases so was trying to avoid that experience again. :D

User avatar
KovuCougar
Posts: 36
Joined: Thu Aug 27, 2020 3:32 am

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by KovuCougar »

I had a thought today for consideration.

When there's big enough jumps under the hood that "older mods" are expected to more or less not work optimally/at all, might it be useful to have a warning, maybe when exiting the Mod configuration window (the same place you get the "configuration for non-installed mods detected" message, which actually would be nice to see what configs it's talking about, particularly when playing around with things, but that's another issue) to list what mods are of for the old, possibly-expected-to-fail version?

User avatar
Luzur
Posts: 22
Joined: Sat Sep 02, 2017 11:26 am

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by Luzur »

Ah, so this is why i get the same stuttering in towns (+ long load times when entering towns) thing, although ive updated most the mods that could be updated.

Also is there any way to get rid of that huge "arrow with a D" mouse pointer ingame?
"Load the muskets"

N_Molson
Posts: 73
Joined: Sat Sep 05, 2020 11:14 pm

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by N_Molson »

Get some issues with 0.10.26 too. Looks very much like a cache issue, because the game usually runs well for some time, then the FPS count collapses (in exterior).

By the way I'm using quite a lot of mods so its hard to say...

User avatar
Interkarma
Posts: 5842
Joined: Sun Mar 22, 2015 1:51 am

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by Interkarma »

There was an issue in Villager Immersion Overhaul with town stutters in 0.10.26 that has been fixed from VIO 5.0.3. Worth double-checking you have this version if using VIO.

viewtopic.php?p=48301#p48301

User avatar
Luzur
Posts: 22
Joined: Sat Sep 02, 2017 11:26 am

Re: [0.10.26a] Stuttering while in towns - Diagnostic tools?

Post by Luzur »

I am using that version, but i fixed the stuttering alot by diong some settings wizardry.
"Load the muskets"

Post Reply