SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Discuss modding questions and implementation details.
User avatar
King of Worms
Posts: 3819
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Post by King of Worms »

Thanks a lot mate, really appreciated!! I will download and test it tomorrow evening and report back, its midnight here ;)

User avatar
King of Worms
Posts: 3819
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Post by King of Worms »

Should I pack the webm vids in dfmod? Because if I place em in movies, update the game withou your patch, run the new executable - game plays the vanila vids

User avatar
pango
Posts: 2830
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Post by pango »

Mmmh based on TheLacus comment, I assumed it would just work... :/
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
King of Worms
Posts: 3819
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Post by King of Worms »

I had a feeling he said that theres already something which should make DFU go thru the various formats of vids when injected as loose files, but now I cant see it in his comment and theres no edit there, so most likely I just hallucinated. :geek:

Im sorry for being such a pain, sometimes I wish I could go thru the code and solve things by myself.

This specific issue is very strange, it started when we moved to 2019lts. I never faced anything like this. "Good" thing is, that I found out that when transcoding to VP8 in Unity, the freezing issue is solved (and game using 80% of my GPU in main menu + low fps ingame - like some process is stuck in background since the video bug)

Only issue now is, that the vids suffered heavy hit in a visual quality.

User avatar
TheLacus
Posts: 1315
Joined: Wed Sep 14, 2016 6:22 pm
Contact:

Re: SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Post by TheLacus »

King of Worms wrote: Sun Dec 13, 2020 11:50 am Should I pack the webm vids in dfmod? Because if I place em in movies, update the game withou your patch, run the new executable - game plays the vanila vids
Yes, extension doesn't matter when the asset is bundled inside a mod.

I never said that this was already working for loose files. pango's change was meant to do it, or at least that's what i understood. What i said is that mod managers detect when the same file is provided by multiple mods, and this is lost by adding support for multiple extensions. :)
Mod System documentation - Learn how to create mods for Daggerfall Unity.
Modder Discussion - General help and discussion for the mod system.
Github Issues - Submit a bug report for the game, including the mod system.

User avatar
pango
Posts: 2830
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Post by pango »

Maybe I misread KoW, that's still not clear.
King of Worms wrote: Sun Dec 13, 2020 11:50 am Should I pack the webm vids in dfmod? Because if I place em in movies, update the game withou your patch, run the new executable - game plays the vanila vids
If you put .webm's in Movies and use the patched version, it should work. I even tested in under Windows 10.
Without the patch it won't work, that's what the patch is for. If it works well, I may submit it for merging.

However you should be able to use any video format in a mod, with either version.
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
King of Worms
Posts: 3819
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: SOLVED - Since 0.10.26 the MODded videos do not play when Reshade is activated

Post by King of Worms »

Well It did not. I will make a completely new instalation and retry.

EDIT: Works on fresh install. The webm files you provided play. Whats more - the videos FINALLY play with Reshade Activated - That means the main issue is solved with this step. So my feeling was correct, and you made it to become a reality. Thanks for the patiance and the will to help and work you did on it :) Damn... this one was really strange bug!

EDIT2: it also works when I create a DFMOD from the webm videos and dont do any transcoding in the Unity. Thats great as well.

PS: I was a bit unsure of the fact I had to do a fresh install to make your patch work - that suggested to me my old install could have been the source of the bug - so I placed the mp4 in the movies in the new install with your patch - and the mp4 were buggy again. This proves my old installation was not the source of the issues.

If this change could be included in the beta release, I would be really glad, thanks a lot!

The last thing Im not sure about:
the old webm vids you gave me for linux release - they have 300mb
these new ones - 250mb
I guess the old ones have better bit rate and I should go with them?


Heres the new start vid Ive made to play with Dream R3

Post Reply