On intro video

Show off your mod creations or just a work in progress.
User avatar
pango
Posts: 1634
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: On intro video

Post by pango » Mon Mar 04, 2019 11:36 pm

You got me :D

http://ks369561.kimsufi.com/~petchema/g ... _44kHz.mp3

Audio speed is already tweaked, but I had to further delay audio by 620ms to mix it back with video (I case anybody wants to rework video separately):

Code: Select all

ffmpeg -i IntroLiveAction.mp4 -itsoffset -0.620 -i DAG2_44kHz.mp3 -c:v copy -c copy -strict experimental -map 0:v:0 -map 1:a:0 -y DAG2.mp4
Anyway, here's the result:
http://ks369561.kimsufi.com/~petchema/g ... s/DAG2.mp4
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
MasonFace
Posts: 355
Joined: Tue Nov 27, 2018 7:28 pm
Contact:

Re: On intro video

Post by MasonFace » Tue Mar 05, 2019 3:18 pm

. . . I had to further delay audio by 620ms to mix it back with video . . .
I've watched on my phone and two PCs and the audio is still about 1/2 second ahead of the video. Not sure if anyone else is experiencing this issue.
Please do other videos as well. The death one. And the intro.
I tried to upscale the Intro, but I can't create anything close to Rhymer's version. I think that should be used instead.

With this live action clip, I had the benefit of starting from the Bethesda website version which is slightly better quality than the one used in vanilla DF. However, the video was not true 30fps, but was instead 15fps with each frame duplicated. I used ffmpeg to remove the duplicate frames, upscaled with ESRGAN, then SFTGAN, then sharpened/denoise filter, and then used Butterflow to interpolate the frame rate back up to true 30fps. Some ghosting can be seen as a result of the interpolation method used but I don't think it looks too bad.

As for the other videos, I'm having a hard time getting good results with the AI upscalers, but I will continue to chip away at it.

User avatar
pango
Posts: 1634
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: On intro video

Post by pango » Tue Mar 05, 2019 4:21 pm

MasonFace wrote:
Tue Mar 05, 2019 3:18 pm
I've watched on my phone and two PCs and the audio is still about 1/2 second ahead of the video. Not sure if anyone else is experiencing this issue.
I can reproduce it with Chromium, maybe that's the issue?
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
King of Worms
Posts: 2481
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: On intro video

Post by King of Worms » Tue Mar 05, 2019 6:12 pm

Ive watched the video Pango linked and it was synced on Firefox.
The result you guys pulled off is incredible. It looks and sounds so clean!!!

I agree that the Rhymers version of the video is hard to beat :)
But I think the sound is not so good... sounds muffled, esp the voice (the whole sound part was remade, new voice was recorded and new background music used) Maybe Pango can try to clean the original video sound and switch it to the Rhymers video? It might be the best version?

Anyway, great work guys!!!

User avatar
MasonFace
Posts: 355
Joined: Tue Nov 27, 2018 7:28 pm
Contact:

Re: On intro video

Post by MasonFace » Tue Mar 05, 2019 8:19 pm

I was only able to do the live action portion of the intro because I was able to download the video from the Bethesda website. The tests that I've done so far with the other videos are just from screenshots. Anyone know how to access the other videos? Are they packed in Arena2 or are they loose files somewhere in the installation folder? I didn't see where Interkarma had a tool to extract the video files like Daggerfall Imaging 2 does with image files.

Also, is there a reference somewhere about which video is which? E.g.: "ANIM0000" = Intro Video
I can reproduce it with Chromium, maybe that's the issue?
King of Worms' results seem to suggest you are correct. As long as it works in game, I guess it doesn't really matter a whole lot. :D

I agree that the Rhymers version of the video is hard to beat :)
But I think the sound is not so good... sounds muffled, esp the voice (the whole sound part was remade, new voice was recorded and new background music used) Maybe Pango can try to clean the original video sound and switch it to the Rhymers video? It might be the best version?
Reading back through this forum thread, it sounds like Rhymer was also not too keen on the audio. I think his vision was to have it re-recorded. I wouldn't mind taking a crack at doing the voice over; the accent wouldn't be hard for me to do, but my microphone is crap. Also, I have that condition where I cringe when I hear my own voice played back, so don't be surprised if I don't follow through on this. :lol:

User avatar
pango
Posts: 1634
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: On intro video

Post by pango » Wed Mar 06, 2019 2:01 am

MasonFace wrote:
Tue Mar 05, 2019 8:19 pm
I was only able to do the live action portion of the intro because I was able to download the video from the Bethesda website. The tests that I've done so far with the other videos are just from screenshots. Anyone know how to access the other videos? Are they packed in Arena2 or are they loose files somewhere in the installation folder? I didn't see where Interkarma had a tool to extract the video files like Daggerfall Imaging 2 does with image files.

Also, is there a reference somewhere about which video is which? E.g.: "ANIM0000" = Intro Video
They're in Arena2 folder, in "VID" format recognized by some players/converters.

ANIM0000 = book intro
ANIM0001 = Bethesda then Daggerfall logos
ANIM0002 = lycanthropy dream
ANIM0003 = (pre-)ending sequence (crowned skeleton rising from sacophagus)
ANIM0004 = vampirism dream
ANIM0005 = Lysandus wakeup
ANIM0006 = King of Worms ending
ANIM0007 = King Eadwyre ending
ANIM0008 = Gortwog ending
ANIM0009 = Sentinel ending
ANIM0010 = Empire ending
ANIM0011 = Emperor's meeting introduction ("The Emperial Palace..." text)
ANIM0012 = Death sequence
ANIM0013 = Lysandus curse lifted
ANIM0014 = Daggerfall ending
ANIM0015 = Underking's ending
DAG2 = Emperor's meeting

In their original quality

Code: Select all

ᐅ for i in *.VID; do ffprobe -hide_banner $i |& grep -v Duration; done
Input #0, bethsoftvid, from 'ANIM0000.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 14 fps, 14 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0001.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 14 fps, 14 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0002.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 9.17 fps, 15.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0003.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 13.83 fps, 15.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0004.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 8.58 fps, 8.58 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0005.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 13 fps, 13 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0006.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 12 fps, 12.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0007.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 8.58 fps, 8.58 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0008.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 12 fps, 12.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0009.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 10 fps, 10.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0010.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 13 fps, 13 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0011.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 5.75 fps, 12.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0012.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 10 fps, 10.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0013.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 12 fps, 12.01 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0014.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 13 fps, 13 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'ANIM0015.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 320x200, 11 fps, 11 tbr, 60.06 tbn
Input #0, bethsoftvid, from 'DAG2.VID':
    Stream #0:0: Audio: pcm_u8, 11111 Hz, mono, u8, 88 kb/s
    Stream #0:1: Video: bethsoftvid, pal8, 256x200, 10 fps, 10.01 tbr, 60.06 tbn
MasonFace wrote:
Tue Mar 05, 2019 8:19 pm
King of Worms' results seem to suggest you are correct. As long as it works in game, I guess it doesn't really matter a whole lot. :D
Can't tell how it works in game; The new VideoPlayer doesn't currently support MP4 format on Linux :(
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
Deepfighter
Posts: 96
Joined: Sun Mar 22, 2015 10:24 am
Location: Iliac-Bay
Contact:

Re: On intro video

Post by Deepfighter » Wed Mar 06, 2019 9:19 am

MasonFace wrote:
Tue Mar 05, 2019 8:19 pm
Anyone know how to access the other videos? Are they packed in Arena2 or are they loose files somewhere in the installation folder? I didn't see where Interkarma had a tool to extract the video files like Daggerfall Imaging 2 does with image files.
There is a tool to convert the .VID videos to .avi. Look here for VIDTitle. There should be an DFVid2AVI.exe included, which should do the trick.
Head of the German Daggerfall translation - www.daggerfalldeutsch.de
and German translator for The Elder Scrolls V: Skyrim and Lore-Expert for The Elder Scrolls: Online

User avatar
MasonFace
Posts: 355
Joined: Tue Nov 27, 2018 7:28 pm
Contact:

Re: On intro video

Post by MasonFace » Wed Mar 06, 2019 1:59 pm

They're in Arena2 folder, in "VID" format recognized by some players/converters.
There is a tool to convert the .VID videos to .avi. Look here for VIDTitle. There should be an DFVid2AVI.exe included, which should do the trick.
Thanks Pango and Deepfighter!
Can't tell how it works in game; The new VideoPlayer doesn't currently support MP4 format on Linux :(
I tried the video out in-game and the video/audio were still not synced. I also tried playing the video in several different media players with the same result. Could the problem be a Windows thing? Which codec are you using? I think I used h264 on video and it plays just fine, but I have no idea if that could be the issue.

User avatar
pango
Posts: 1634
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: On intro video

Post by pango » Wed Mar 06, 2019 2:54 pm

MasonFace wrote:
Wed Mar 06, 2019 1:59 pm
I tried the video out in-game and the video/audio were still not synced. I also tried playing the video in several different media players with the same result. Could the problem be a Windows thing?
Tried several players too, and all worked... :(
Haven't tried on other hardware, but never had issues with videos on that PC, so I'm puzzled
MasonFace wrote:
Wed Mar 06, 2019 1:59 pm
Which codec are you using? I think I used h264 on video and it plays just fine, but I have no idea if that could be the issue.
I'm not using any codec, I didn't touch the video feed, it's copied straight from your file.
I used ffmpeg, using the command shown before to manage the streams.
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
pango
Posts: 1634
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: On intro video

Post by pango » Wed Mar 06, 2019 6:23 pm

pango wrote:
Wed Mar 06, 2019 2:54 pm
Haven't tried on other hardware, but never had issues with videos on that PC, so I'm puzzled
Worked:
  • firefox (Linux, Windows 10)
  • vlc (Linux, Windows 10)
  • mpv player (Linux)
  • mplayer (Linux)
  • ffplay (Linux)
  • xplayer (Linux)
Didn't work:
  • "Films and TV" (Windows 10)
  • Windows Media Player (Windows 10)
  • Chrom(ium) (Linux, Windows 10)
I assume ffmpeg's -itoffset uses some feature that's not universally supported, will see how I can fix that...
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

Post Reply