levitateMotor isn't colliding properly

Discuss coding questions, pull requests, and implementation details.
User avatar
Interkarma
Posts: 3174
Joined: Sun Mar 22, 2015 1:51 am

Re: levitateMotor isn't colliding properly

Post by Interkarma » Mon Sep 10, 2018 10:48 pm

I think so, yeah. Although it's hard to reproduce, so it might have been there earlier.

With the latest advanced climbing changes where you can hold onto wall, I find very slowly mantling top of climb can help make it happen. I just gently tap W near the top to get right on the edge, then go over top in one movement.

If you don't have any luck, I'm happy to help chase it down when I can.

Prester Lewin
Posts: 2
Joined: Thu Sep 13, 2018 2:16 pm

Re: levitateMotor isn't colliding properly

Post by Prester Lewin » Thu Sep 13, 2018 3:09 pm

I've had the same issue as Pango when climbing a strictly rectangular part of a building in a city. Get to the top and there's about a 1 in 5 or 10 chance of liftoff. Different buildings, different towns. I think it seems to place me at the NE corner of the grid square containing the town if that makes sense, so the compass says I'm looking SW. Maybe I'm at the min or max co-ords?

Happening in Win #132 64 bit.

User avatar
MeteoricDragon
Posts: 114
Joined: Mon Feb 12, 2018 8:23 pm

Re: levitateMotor isn't colliding properly

Post by MeteoricDragon » Sun Sep 16, 2018 8:13 pm

This issue is now fixed in the latest group of updates I'll be submitting via PR to Interkarma.

Post Reply