Properties in inspector not appearing anymore

Discuss coding questions, pull requests, and implementation details.
Post Reply
User avatar
MeteoricDragon
Posts: 141
Joined: Mon Feb 12, 2018 8:23 pm

Properties in inspector not appearing anymore

Post by MeteoricDragon » Mon Oct 01, 2018 2:26 am

I used to be able to see the Components for the Player, like the motors, and could modify public variables via inspector. But somehow it is no longer showing in inspector, do I need to select something?

User avatar
Interkarma
Posts: 5183
Joined: Sun Mar 22, 2015 1:51 am

Re: Properties in inspector not appearing anymore

Post by Interkarma » Mon Oct 01, 2018 3:16 am

Not sure what's wrong, I can still see the usual properties in Inspector with PlayerAdvanced selected in Hierarchy. Maybe use Layout drop-down and select "revert factory settings". Possibly something went wrong with layout.

If that solves the problem, be sure to save your preferred layout once you've set everything up again the way you like it. Then you can just reset to a good baseline whenever needed.

If you're still stuck, post a screen cap of what you're seeing and maybe we'll see the problem. For comparison, this is my my layout below with PlayerAdvanced selected.

ik-layout.png
ik-layout.png (314.54 KiB) Viewed 486 times

User avatar
MeteoricDragon
Posts: 141
Joined: Mon Feb 12, 2018 8:23 pm

Re: Properties in inspector not appearing anymore

Post by MeteoricDragon » Mon Oct 01, 2018 3:30 am

Using your screenshot I figured out that I needed to select playerAdvanced for its properties to show up in my inspector tab :)

User avatar
Interkarma
Posts: 5183
Joined: Sun Mar 22, 2015 1:51 am

Re: Properties in inspector not appearing anymore

Post by Interkarma » Mon Oct 01, 2018 7:30 am

Great, happy you got it sorted. :)

Post Reply