[0.10.22] FadeInProgress not set to true during Fast Travel

Curated user bug reports with enough information to reproduce issue. Moderators will move topics here from Help & Support once a bug is confirmed and enough information has been provided.
Post Reply
User avatar
Ralzar
Posts: 1065
Joined: Mon Oct 07, 2019 4:11 pm
Location: Norway

[0.10.22] FadeInProgress not set to true during Fast Travel

Post by Ralzar » Sun May 03, 2020 3:41 pm

I just ran into a bug with my mod which took a little while to spot why was happening. Now, I've only done testing in the editor with the code for the upcoming build, so I can't say if this is still the case when the livebuild is actually compiled.

If you are inside a building, exit it, immediately go into the travelmap and fast travel, DaggerfallUI.Instance.FadeBehaviour.FadeInProgress will not be set to true.

I am assuming this is because the fade behaviour for transitioning out of the building is not finished when I activate the fast travel map. If I exit the building, wait a second and then fast travel; it works normally.


This naturally has little impact on the game normally but my mod uses FadeInProgress false/true to determine if the player is fast traveling or not. So when this is not set to true while fast traveling, the player starves to death during the journey :D
I assume all that's needed to fix it is a small check for the fast travel code to make sure FadeInProgress is set correctly.
My released mods

"I feel like Ralzar specifically wrote those mods for me and then said "Use them". Just so he could watch me die more."
-FuzzyBeanPlays

User avatar
Interkarma
Posts: 5473
Joined: Sun Mar 22, 2015 1:51 am

Re: FadeInProgress not set to true during Fast Travel

Post by Interkarma » Sun May 03, 2020 4:44 pm

I've noticed this occasionally as well, but was never able to pin down a cause. Thanks for the good spot, that information sounds like what I was missing.

Will move to bug reports so this one can be improved.

Post Reply