Page 8 of 8

Re: Daggerfall Unity 0.4.x - "DragonBreak" Update

Posted: Mon Nov 06, 2017 6:42 am
by Interkarma
New Live Builds are available for DragonBreak #92. Here's a summary of changes:
  • Fixed quest item marker alignment after it was broken by other changes
  • Pre-placed treasure pile billboards such as the Orsinium and Daggerfall treasure rooms can now be looted
  • Wayrest painting now shows correct flavour text on use-click (still has info-click limitation)
  • ItemUsedDo now triggers on equip or use
  • Implemented "dropped anItem at aPlace" condition (needs testing)
  • TotingItemAndClickedNpc action now removes item like classic
  • Nystul: Talk window progress and bugfix
  • TheLacus: Mod settings window enhancements
  • TheLacus: Colour picker support in UI
  • Allofich: INI options to optionally show material type for helms and shields (see below)
  • Allofich: Dungeon texture options and fixes (see below)
  • Allofich: Fixed spellbook magic swirl, climate texture fixes
  • Allofich: Identify classic dungeon water level, add basic water sound effect support
For Allofich's new INI settings, these are:

  • 0 - Don't show material (like classic). Default.
  • 1 - Show for non-leather and chain materials
  • 2 - Same as 1 but show chain
  • 3 - Show all
  • 0 = classic textures
  • 1 = climate-based textures, using classic algorithm for picking among them. Main story dungeons have classic textures.
  • 2 = climate-based textures for all dungeons
  • 3 = Random selection from all textures (DF Unity implementation from before). Main story dungeons have classic textures. Sewer texture fix added so out-of-range textures shouldn't be used.
  • 4 = Random selection from all textures (DF Unity implementation from before) for all dungeons. Sewer texture fix.

Re: Daggerfall Unity 0.4.x - "DragonBreak" Update

Posted: Mon Nov 06, 2017 11:04 am
by Biboran
ini ssetings may be added in laucher like adittional menu?

Re: Daggerfall Unity 0.4.x - "DragonBreak" Update

Posted: Wed Nov 08, 2017 5:53 am
by Jay_H
I'm writing a quest to test the item dropping condition. I tried running one of the classic quests where you drop an item in an inn, but the condition failed. I'll try to make it simpler, since some classic quests were written in rather roundabout ways :)

Re: Daggerfall Unity 0.4.x - "DragonBreak" Update

Posted: Wed Nov 08, 2017 9:46 pm
by Interkarma
Thanks for testing. Condition likely needs some work - I built it out in a hurry, which usually doesn't yield good results. I will return to this and take another look as soon as I can.

Re: Daggerfall Unity 0.4.x - "DragonBreak" Update

Posted: Fri Nov 10, 2017 5:26 am
by Jay_H
The quest action as written -- dropped _item_ at _place_ -- works! I just tested it with this quest:

Code: Select all

Item _item_ mark

Person _questgiver_ group Questor male

Place _place_ local random

Clock _timer_ 01:00

--	Quest start-up:
	start timer _timer_
          get item _item_

_timer_ task:
	end quest

_qgclicked_ task:
          dropped _item_ at _place_
          give pc nothing
	end quest
Classic had a roundabout way of demanding a "while pc at" condition first, so this is a welcome change. The removal worked and the victory message came up, so the first test is a pass.

Re: Daggerfall Unity 0.4.x - "DragonBreak" Update

Posted: Fri Nov 10, 2017 11:11 pm
by Interkarma
Thanks for testing Jay. :)

Re: Daggerfall Unity 0.4.x - "DragonBreak" Update

Posted: Thu Dec 14, 2017 9:11 pm
by Midknightprince
1. Morgiah's wedding invitation, and the King of Worms summons (vie zombie) show up at exactly the same time, even if I just stand there and wait.
The soul of a lich quest can be done no problem, but the wedding invitation never shows up in the inventory even tho I get the message that it did (I remember getting it when you first rolled out the MQ system a few times, that's why I bring this up).
No big deal, just something...also Morgiah's initial invitation stays in the inventory (so far) after her quest is done (indefinitely on my end), tho I think I remember you saying something about this in weeks past.

2. Something about the Werebeast quest is confusing me, perhaps you can clarify..
On the unofficial pages it says that quest becomes available after lvl 5 (that and Privateers hold being the only prerequisite).
My guy is lvl 22, have made it to freeing Medora, have done some side story quests even (Mynisera's Letters for instance, Concern for Nulfaga etc), still no talking to Cyndassa (I even raised her rep to 50).
So is it set up to go off AFTER Lysandus' Revenge in DFU (I have not reached this point yet in MQ), or are the unofficial pages wrong ?
Seems like i should be able to get this thing anytime according to the latter, but trying to talk to her does nothing, so maybe I'm missing something..

That's it so far.
Since you turned the "other" switches on, dungeon delving feels complete (except for getting your butt kicked by a lich), So I've pretty much been going nuts exploring random dungeons to make sure they all work (don't know what it is, but it's so much fun), and getting lost.

Whoever decided to put click to attack in is ingenious (even tho I voted against it).
I am shocked, appalled, and in love with it all at the same time.
Like......what the frick.....I feel like a sell out.
But it feels like it was always a part of this game, and that for me is something I can't quite find the words for...

Ok, I'm gonna go explore the innards of Castle Wayrest now, get a painting, and check them switches.
Let me know about the werewolf thing..