[MOD] Trees Of Daggerfall

A curated forum for approved mods. Users are unable to create new topics in this forum but can reply to existing topics. Please message a moderator to have your mod moved into this forum area.
User avatar
Midknightprince
Posts: 1171
Joined: Fri Aug 11, 2017 6:51 am
Location: San Antonio TX
Contact:

Re: [MOD] Trees Of Daggerfall

Post by Midknightprince » Fri Oct 25, 2019 6:39 pm

I recommend 2 view distance max "if" you use tedious travel, or just walk everywhere.
The zoning is a bit choppy even at 2, but at 4 it is like an un-interactive slide show until you actually get in the zone), and that's ONLY with the 3d trees, so without and in snowy weather I get 60+ (if my monitor went that high)
I get maybe 50 fps when I am just playing at 2, and at 4 it's about 30 fps, maybe less, so it has improved, but you're gonna need a good card.

You can still see stuff good at 2, and the only reason to go to 4 is so you can see land masses off the coast, and Tigonis....can't forget about Tigonis..
Traveling cross country at 4 doesn't do much (except lag the zone with this on), as you can't really see stuff that far away, unless like I said your on the coast, or a really big hill, but you're never gonna see a location that far away.

Just my advice..

edited to fix my flub
Last edited by Midknightprince on Tue Oct 29, 2019 3:04 am, edited 1 time in total.
Check out my YouTube Channel!

Firebrand
Posts: 279
Joined: Thu Jul 18, 2019 6:07 pm

Re: [MOD] Trees Of Daggerfall

Post by Firebrand » Fri Oct 25, 2019 7:35 pm

strata wrote:
Fri Oct 25, 2019 5:40 pm
Ah... 11th of Morning Star, that's it! Thank you. Time to loiter around for a while so I can try these trees out.

(Come to think of it, I don't think I ever figured out whether the start date & time in Daggerfall was preset or randomized before)
The start date should be 4th of Morning Star, 3E405 ;)

strata
Posts: 9
Joined: Wed Nov 21, 2018 3:09 am

Re: [MOD] Trees Of Daggerfall

Post by strata » Fri Oct 25, 2019 8:20 pm

Appreciate the advice.

Has a density variable been considered as a means of allowing people to dynamically lessen the performance impact? I have skimmed most of this and the 'technical help' thread and don't believe I saw it mentioned, but apologies if this is a redundant idea.

I would imagine an implementation as simple as having an empty GameObject with probability of spawning vs. the replacement tree mesh of 1-densityVariable would work... since the trees are just flats in the base game, there wouldn't be any gameplay impact from having fewer trees in the world.

Just an idea. Lovely mod and artwork - thanks to all who've helped build it.

clocknova
Posts: 17
Joined: Wed Jul 10, 2019 7:50 pm

Re: [MOD] Trees Of Daggerfall

Post by clocknova » Thu Oct 31, 2019 6:43 pm

I get some very unusual results whenever I have Trees of Daggerfall and Real Grass 2 installed and activated at the same time. With either one enabled alone, everything looks fine. But if I enable them both I get results like you can see in the screenshots below.

I'm running the latest MacOS build, and I have made sure I have the Mac version of both mods installed.
Attachments
Screen Shot 2019-10-31 at 2.28.20 PM.jpg
Screen Shot 2019-10-31 at 2.28.20 PM.jpg (821.99 KiB) Viewed 584 times
Screen Shot 2019-10-31 at 2.07.44 PM.jpg
Screen Shot 2019-10-31 at 2.07.44 PM.jpg (640.41 KiB) Viewed 584 times

BadLuckBurt
Posts: 296
Joined: Sun Nov 05, 2017 8:30 pm

Re: [MOD] Trees Of Daggerfall

Post by BadLuckBurt » Thu Oct 31, 2019 6:51 pm

clocknova wrote:
Thu Oct 31, 2019 6:43 pm
I get some very unusual results whenever I have Trees of Daggerfall and Real Grass 2 installed and activated at the same time. With either one enabled alone, everything looks fine. But if I enable them both I get results like you can see in the screenshots below.

I'm running the latest MacOS build, and I have made sure I have the Mac version of both mods installed.
Silly question but have you tried changing their load order? Also, what happens when you disable all mods except those two? It looks damn crazy, that's for sure.

clocknova
Posts: 17
Joined: Wed Jul 10, 2019 7:50 pm

Re: [MOD] Trees Of Daggerfall

Post by clocknova » Thu Oct 31, 2019 7:11 pm

BadLuckBurt wrote:
Thu Oct 31, 2019 6:51 pm
Silly question but have you tried changing their load order? Also, what happens when you disable all mods except those two? It looks damn crazy, that's for sure.
I should have indicated above that I've tried both of those things. The screenshots below are with just these two mods installed, in either order.
Attachments
Screen Shot 2019-10-31 at 3.07.19 PM.jpg
Screen Shot 2019-10-31 at 3.07.19 PM.jpg (996.17 KiB) Viewed 571 times
Screen Shot 2019-10-31 at 3.04.33 PM.jpg
Screen Shot 2019-10-31 at 3.04.33 PM.jpg (591.07 KiB) Viewed 571 times

BadLuckBurt
Posts: 296
Joined: Sun Nov 05, 2017 8:30 pm

Re: [MOD] Trees Of Daggerfall

Post by BadLuckBurt » Thu Oct 31, 2019 7:24 pm

clocknova wrote:
Thu Oct 31, 2019 7:11 pm
BadLuckBurt wrote:
Thu Oct 31, 2019 6:51 pm
Silly question but have you tried changing their load order? Also, what happens when you disable all mods except those two? It looks damn crazy, that's for sure.
I should have indicated above that I've tried both of those things. The screenshots below are with just these two mods installed, in either order.
Cool, as long as you got that covered, just ruling out possible causes. Sadly, I'm out of ideas, hopefully someone else knows what's up. Trippy stuff

clocknova
Posts: 17
Joined: Wed Jul 10, 2019 7:50 pm

Re: [MOD] Trees Of Daggerfall

Post by clocknova » Thu Oct 31, 2019 7:44 pm

I think I know what is causing it, but I don't really know why. With just those two mods activated, and the draw distance set to 1 or 2, everything looks fine. When I set draw distance to 3, the ground texture disappears, but everything else is okay. When I set it to 4, all the other textures go nuts. With all my other mods turned on, the ground texture goes black at a distance of 1 and 2, and the rest of the textures freak out at 3 and 4.

Would this be a memory issue? I have 4 GB of VRAM, which should be enough, even though I have an older machine. Oddly enough, even with the massive errors, performance remains good. I don't know what to make of it.

User avatar
Hazelnut
Posts: 1979
Joined: Sat Aug 26, 2017 2:46 pm
Contact:

Re: [MOD] Trees Of Daggerfall

Post by Hazelnut » Fri Nov 01, 2019 12:23 am

It's possible the change I made to core affects the grass mod in some way as I am not familiar with it and have never used it. The change only kicks in when a 3d model replaces a nature flat - i.e. trees mod.

Maybe TheLacus would have more insight?
See my mod code for examples of how to change various aspects of DFU: https://github.com/ajrb/dfunity-mods

clocknova
Posts: 17
Joined: Wed Jul 10, 2019 7:50 pm

Re: [MOD] Trees Of Daggerfall

Post by clocknova » Fri Nov 01, 2019 10:30 am

Hazelnut wrote:
Fri Nov 01, 2019 12:23 am
It's possible the change I made to core affects the grass mod in some way as I am not familiar with it and have never used it. The change only kicks in when a 3d model replaces a nature flat - i.e. trees mod.

Maybe TheLacus would have more insight?
It's possible. I don't recall this happening with previous versions. Trying to use both mods at once usually just slowed my machine down to a crawl, especially at a draw distance of 4. Now it runs great, but looks like this.

Is this something deserving of a bug report? It seems more mod related than anything, but I haven't heard of anyone else having this problem. Could be something on my end.

Post Reply