[MOD] Loading Screen

A curated forum for approved mods. Users are unable to create new topics in this forum but can reply to existing topics. Please message a moderator to have your mod moved into this forum area.
Post Reply
User avatar
Daniel87
Posts: 16
Joined: Thu Nov 28, 2019 6:25 pm

Re: [MOD] Loading Screen

Post by Daniel87 » Fri Dec 06, 2019 9:50 pm

TheLacus wrote:
Fri Dec 06, 2019 9:26 pm
Daniel87 wrote:
Fri Dec 06, 2019 9:02 pm
When I tried to kick in a door into a house at a graveyard, the loading screen got stuck and the word loading went to infinity.
When I disable the mod and kick in the door, I cannot get in and only get prompted following message: "House has nothing of value".
When you run the game without this mod, does the message: "House has nothing of value" appears but you can still play or the game is stuck on a black screen? If is the first case, the issue is probably that game raises an event when transition start but never raises an end event because it print message and returns early.
Yes, when I deactivate the mod, I get the usual message that the house got nothing of value.
When I use the mod, I get stuck on the loading screen, though I can hear the normal game sounds like hitting, jumping and can see the curser when I go to the inventory.

User avatar
TheLacus
Posts: 1095
Joined: Wed Sep 14, 2016 6:22 pm
Contact:

Re: [MOD] Loading Screen

Post by TheLacus » Sat Dec 07, 2019 3:39 pm

Daniel87 wrote:
Fri Dec 06, 2019 9:50 pm
TheLacus wrote:
Fri Dec 06, 2019 9:26 pm
Daniel87 wrote:
Fri Dec 06, 2019 9:02 pm
When I tried to kick in a door into a house at a graveyard, the loading screen got stuck and the word loading went to infinity.
When I disable the mod and kick in the door, I cannot get in and only get prompted following message: "House has nothing of value".
When you run the game without this mod, does the message: "House has nothing of value" appears but you can still play or the game is stuck on a black screen? If is the first case, the issue is probably that game raises an event when transition start but never raises an end event because it print message and returns early.
Yes, when I deactivate the mod, I get the usual message that the house got nothing of value.
When I use the mod, I get stuck on the loading screen, though I can hear the normal game sounds like hitting, jumping and can see the curser when I go to the inventory.
Thank you! This issue requires both a new game and mod builds to be released for fix. In the meanwhile you can disable Dungeon and Building transitions from mod settings and still benefit of loading screen during save/fast travel.
Mod System documentation - Learn how to create mods for Daggerfall Unity.
Modder Discussion - General help and discussion for the mod system.
Github Issues - Submit a bug report for the game, including the mod system.

User avatar
TheLacus
Posts: 1095
Joined: Wed Sep 14, 2016 6:22 pm
Contact:

Re: [MOD] Loading Screen

Post by TheLacus » Sun Dec 08, 2019 2:04 pm

Version 2.4.1 is available on Nexus with fix from previous post.
Mod System documentation - Learn how to create mods for Daggerfall Unity.
Modder Discussion - General help and discussion for the mod system.
Github Issues - Submit a bug report for the game, including the mod system.

User avatar
pango
Posts: 2164
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: [MOD] Loading Screen

Post by pango » Sun Dec 08, 2019 5:00 pm

I don't know how much it matters, but all presets say "version mismatch! (1.4/1.5)"
presets version mismatch.jpg
presets version mismatch.jpg (51.54 KiB) Viewed 163 times
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
Midknightprince
Posts: 1180
Joined: Fri Aug 11, 2017 6:51 am
Location: San Antonio TX
Contact:

Re: [MOD] Loading Screen

Post by Midknightprince » Mon Jan 13, 2020 8:27 pm

I think this one stopped working correctly, it's not showing the background pictures for me..
The level percent, the model viewer, and all the other texts show up fine, but I can't get the pictures to show up,
If somebody wants to boot this up with vanilla and see what happens that would be cool then I can go through all my mods and see if there's a conflict..
I'm playing on the latest live build Windows 10x64, and I've already got the December version of loading screen.
I'm thinking it might be the Shader presets that came with king of worms dream ( it takes a minute to boot up dfu with that one on).
So if it works for you in vanilla let me know so I can start going through the mods
Check out my YouTube Channel!

Post Reply