Page 2 of 2

Re: 0.7.32 (Win 7 x64) - Some modded lights are buggy

Posted: Sun Apr 28, 2019 8:41 pm
by King of Worms
Its not solved, I removed 90% of the lights yet the outside lights (like the round one) still get reverted to low res. No idea... I somehow skipped on this one and hope Alexander Sig replaces all light sprites with his models ,)

Re: 0.7.32 (Win 7 x64) - Some modded lights are buggy

Posted: Fri May 03, 2019 6:42 pm
by TheLacus
TheLacus wrote:
Fri Feb 08, 2019 8:10 pm
Light billboards for exteriors use an atlas, so you need to enable read/write flag and ensure not to exceed atlas size and cause textures to be resized. Please try with a single texture like i did here:
2019.02.08-21.02.png
King of Worms wrote:
Sun Apr 28, 2019 8:41 pm
Its not solved, I removed 90% of the lights yet the outside lights (like the round one) still get reverted to low res.
Does it work if you try with a single texture like i did in my post above? I'm not sure what you mean with reverted to low res. Please confirm that the issue is that textures appear at a lower resolution that expected and not that the original (low resolution) texture is used instead.

Note that the issue with static interior billboards (lights and npcs) has been introduced with most recent build so i don't think is related with this report.

Re: 0.7.32 (Win 7 x64) - Some modded lights are buggy

Posted: Wed May 29, 2019 11:35 am
by TheLacus
A potential issue for lights is a size mismatch for albedo and emission maps, so i've pushed a PR to enforce that additional textures inside an atlas have the same size as the albedo textures. I don't think this is what you have reported here but I couldn't find any issue that would cause textures to be resized, beside the known atlas max size overflow. If this bug report is still relevant please check my previous post, otherwise i think it can be closed :)

Re: 0.7.32 (Win 7 x64) - Some modded lights are buggy

Posted: Thu May 30, 2019 9:40 am
by King of Worms
Hi mate, I removed majority of lights from my mod, because Alexander Sig included them in his Handpainted Models and I consider that to be the superior solution.

I left the light shown in the opening post on the 2nd screen in my mod, and now it looks correct in my game when outside. So its solved. No idea how tho, and no idea if more upscaled lights included in my mod would recreate the issue. I dont really want to try that honestly, if thats not a problem?

With "reverted to low res" I ment the behaviour shown in th eopening post in the 2nd screenshot. To me it appears its reverted to vanila.. most definitely a vanila...

Sry it took me so long to reply here, I somehow lost this post :X

EDIT: I just could not resist, placed the modded lights as a loose files to the textures and got a mixed result.
The light is no more reverted to vanilla
But it has some strange artefact on in
Better than before tho... I think I will move on from the modding the ligth sprites, theres no need to do that since they are replaced with models which look really good now.
Untitled-1.jpg
Untitled-1.jpg (362.48 KiB) Viewed 342 times