Page 1 of 2

Village buildings not visible when arriving without fast travel

Posted: Sat Feb 08, 2020 8:28 pm
by haloterm
I am not sure if this is related to using the Distant Terrain Mod or a bug, just want to ask:

Has anybody had the problem that you walk on foot from one village to another and, when you arrive at your target, you get the "you are entering ..." message and see the roads of the village, but every building is missing? Making a fast travel then shows the building correctly.

Have seen this today while I was hiking a bit around Daggerfall City. I went from Ripwych Commons (the village that is northwest of Daggerfall) in southeastern direction until I reached the hills in the north of Daggerfall City. I then basically followed Daggerfall's city wall, on top of the hills, going west to east, having a great view on the city, the castle and the Iliac Bay in the background. Beautiful, really. After I passed the northeastern corner of the city, I turned south, went for a while, then turned southwest, to finally reach Copperfield Manor. And then the bug above happend.

I intend to test this again with Distant Terrain disabled and Mountains & Hills as alternative, and also with no terrain mod at all (altough that will be a very boing trip due to the missing landscape variations). But still wanna know if others know this problem?

(By the way, the distance I set in the Daggerfall Unity settings is 2, because this is usally enough for far viewing distances in the Distant Terrain mod and better for performance.)


Edit: Two observations:

1. Did not happen with Mountains & Hills

2. Did not happen again with Distant Terrain mod when I set distance setting in DFU to 3. Will keep it that way...

Re: Village buildings not visible when arriving without fast travel

Posted: Sat Feb 08, 2020 9:45 pm
by pango
That the kind of bug you think has been eradicated, but keeps coming back...

Re: Village buildings not visible when arriving without fast travel

Posted: Sun Feb 09, 2020 7:38 am
by JorisVanEijden
Here's another recent example: viewtopic.php?f=5&t=3368 (middle picture)

Re: Village buildings not visible when arriving without fast travel

Posted: Sun Feb 09, 2020 8:04 am
by haloterm
pango wrote:
Sat Feb 08, 2020 9:45 pm
That the kind of bug you think has been eradicated, but keeps coming back...
Ah, I see! Thanks for confirming.

Re: Village buildings not visible when arriving without fast travel

Posted: Sun Feb 09, 2020 12:21 pm
by dani26795
Ah yes, this happened me once on 0.10.17 when I reached a dungeon location without fast travelling. Saving and reloading made the typical lake and entrance mound spawn properly.

Re: Village buildings not visible when arriving without fast travel

Posted: Mon Feb 10, 2020 12:41 am
by Ommamar
D

Re: Village buildings not visible when arriving without fast travel

Posted: Tue Feb 11, 2020 7:57 pm
by Hazelnut
I guess we need to ascertain 2 things: 1) does this ever occur without mods?, 2) what mods & ordering enables it?

Re: Village buildings not visible when arriving without fast travel

Posted: Wed Feb 12, 2020 2:00 am
by Helegad
Ommamar wrote:
Mon Feb 10, 2020 12:41 am
might of
Image

Re: Village buildings not visible when arriving without fast travel

Posted: Wed Feb 12, 2020 2:49 am
by Jay_H
Helegad, if we're going to point out minor grammatical errors here, this place is going to fall apart quickly. It's not helping anyone.

I agree with Hazelnut's point: I don't recall this ever occurring without mods. I know we previously pointed to DREAM - Sound and its method of loading into the game; we'll have to find a common denominator. haloterm, if you can show the mod loadout you used when this occurred, that'd be a big help.

Re: Village buildings not visible when arriving without fast travel

Posted: Wed Feb 12, 2020 4:26 am
by Helegad
My bad, I meant it in humour. :mrgreen: