Page 1 of 2

Mod load order and settings not being saved

Posted: Wed Jul 10, 2019 7:54 pm
by clocknova
Just installed the latest build on MacOS, but the game will not save any of my mod data. Reordering the mods, activating and deactivating them, then quitting the game and restarting results in all of my mods reverting to alphabetical order and all activated.

Any ideas?

Re: Mod load order and settings not being saved

Posted: Wed Jul 10, 2019 8:18 pm
by TheLacus
Load order is saved to StreamingAssets\Mods\Mod_Settings.json. Check if this file is generated; if not, please provide the log file found at /Users/Username/Library/Logs/Unity/Player.log :)

Re: Mod load order and settings not being saved

Posted: Wed Jul 10, 2019 8:29 pm
by clocknova
Okay, I found this in the log file:

Failed to write mod settings: Access to the path "/private/var/folders/5c/s4hd_4sx7qn5lj86w2h1bzpr0000gn/T/AppTranslocation/2290D9C4-8387-4323-943F-58ADD6CBC562/d/DaggerfallUnity.app/Contents/Resources/Data/StreamingAssets/Mods/Mod_Settings.json" is denied.

Not sure what is going on here. Why would it be trying to write the setting file there instead of into the mod folder? It should read:
"/Applications/Games/Daggerfall Unity/DaggerfallUnity.app/Contents/Resources/Data/StreamingAssets/Mods/Mod_Settings.json"

[THELACUS?] 0.8.6 (Mac Universal) Mod settings not being written

Posted: Thu Jul 11, 2019 9:27 pm
by clocknova
Just installed the latest build on MacOS, but the game will not save any of my mod data. After checking a but, I found this in the log file:

Failed to write mod settings: Access to the path "/private/var/folders/5c/s4hd_4sx7qn5lj86w2h1bzpr0000gn/T/AppTranslocation/2290D9C4-8387-4323-943F-58ADD6CBC562/d/DaggerfallUnity.app/Contents/Resources/Data/StreamingAssets/Mods/Mod_Settings.json" is denied.

Not sure what is going on here. Why would it be trying to write the setting file there instead of into the actual mod folder? The proper data path on my machine is:
"/Applications/Games/Daggerfall Unity/DaggerfallUnity.app/Contents/Resources/Data/StreamingAssets/Mods/Mod_Settings.json"

Re: 0.8.6 (Mac Universal) Mod settings not being written

Posted: Thu Jul 11, 2019 10:56 pm
by Interkarma
Thanks for report. The StreamingAssets folder is being queried out of Unity itself - strange that it provides that path. I'll assign this one to TheLacus for now to check the mod settings serialization code for any anomalies, but I'm not sure if he has a Mac to test properly with (I don't either).

Contributors: any of you working on a Mac and might be able to take a closer look?

Re: [THELACUS?] 0.8.6 (Mac Universal) Mod settings not being written

Posted: Thu Jul 18, 2019 6:10 pm
by TheLacus
Path is defined as following:

Code: Select all

ModDirectory = Path.Combine(Application.streamingAssetsPath, "Mods");
Can you check if you have other error messages in the log? For example "Mod Directory doesn't exist".

Possibly relevant links:
Interkarma wrote:
Thu Jul 11, 2019 10:56 pm
Thanks for report. The StreamingAssets folder is being queried out of Unity itself - strange that it provides that path. I'll assign this one to TheLacus for now to check the mod settings serialization code for any anomalies, but I'm not sure if he has a Mac to test properly with (I don't either).

Contributors: any of you working on a Mac and might be able to take a closer look?
I don't have a Mac, feedback from players on that platform would be much useful.

Re: Mod load order and settings not being saved

Posted: Thu Aug 08, 2019 2:36 pm
by clocknova
The problem still exists as of the current alpha build.

Re: Mod load order and settings not being saved

Posted: Thu Aug 08, 2019 2:55 pm
by TheLacus
Can you try to move the game outside of Applications?

Re: Mod load order and settings not being saved

Posted: Fri Aug 09, 2019 4:46 am
by clocknova
No change. Tried moving it to several locations. Cannot find any further error messages in log file.

I'm happy to perform any tests on my Mac that will help you. Just let me know.

EDIT:

Okay, I've found that if I open the app bundle and navigate to "DaggerfallUnity.app/Contents/MacOS/DaggerfallUnity" and launch the Unix executable, which launches the game through the MacOS terminal app, everything works fine. Reverting to launching the game the standard way by double clicking the app bundle itself results in the original problem returning.

Re: Mod load order and settings not being saved

Posted: Tue Aug 13, 2019 1:19 pm
by clocknova
Does anyone else have the ability to test this so I can find out whether or not it's a problem on my end?