Question About Unity vs Classic In Versions

Post here if you need help getting started with Daggerfall Unity or just want to clarify a potential bug. Questions about playing or modding classic Daggerfall should be posted to Community.
Post Reply
Teralitha
Posts: 260
Joined: Wed Jul 17, 2019 3:44 pm

Question About Unity vs Classic In Versions

Post by Teralitha » Fri Jul 19, 2019 7:17 pm

Does it matter to DFU what version of classic daggerfall you are using? I wonder this because DFU is installed inside a classic install, and the classic install may be a different version that what unity was designed for.

For example, the classic daggerfall I am playing, is from the wiwiki page, and its version 2.15. But not that long ago it was 2.14, and of course... older version going back. DFU was started before 2.15. Does it matter what classic version one has in relation to DFU? If so, is DFU updated for the changes?

User avatar
pango
Posts: 1405
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: Question About Unity vs Classic In Versions

Post by pango » Fri Jul 19, 2019 7:37 pm

2.14, 2.15, You must mean the version of DaggerfallSetup, not Daggerfall itself, that's stuck at version 1.07.213.

I guess it doesn't matter.
According to the changelog, most recent changes concern translations, and Daggerfall Unity is not compatible with translation patches, so you shouldn't use what has been modified in the recent versions of DaggerfallSetup in the first place.
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
Jay_H
Posts: 2714
Joined: Tue Aug 25, 2015 1:54 am

Re: Question About Unity vs Classic In Versions

Post by Jay_H » Fri Jul 19, 2019 8:12 pm

A lot of people have had problems using the Anthology version of Daggerfall. The Live Builds page recommends you use DaggerfallSetup.

Post Reply