Strange Stuttering even at locked 60fps

Post here if you need help getting started with Daggerfall Unity or just want to clarify a potential bug. Questions about playing or modding classic Daggerfall should be posted to Community.
GreatSphynx
Posts: 10
Joined: Thu Aug 01, 2019 11:09 am

Strange Stuttering even at locked 60fps

Post by GreatSphynx » Sun Aug 04, 2019 10:24 pm

I looked around at other topics to see if anyone had a similar issue, and while I saw posts about lagging or stuttering I didn't really see anything that matched my exact issue.

When playing the game sometimes the game will just "jump" a little bit, as in my character will be walking smoothly and then suddenly hop forward a little bit. I've tested with the debug FPS counter up and my game remains locked at 60fps even when this occurs. I know there are some issues around the light shadows settings, but this occurs even when I have those disabled.

My system is capable of running the game at my monitor refresh rate of 144hz with mods enabled, however it introduces some stuttering on objects when strafing or moving fast, so for best performance and smoothness I set my monitor refresh to 60hz and enable Vsync to keep things nice.

On average my system usually is using about 20-40% CPU and 20-50% of my GPU and around 14gb of 32gb of memory. There are no noticeable spikes to either whenever these little stutters occur, which seems to be between every 5-10 seconds.

I am playing with pretty much all available graphical mods (Post Processing, DREAM, Distant Terrain, Enhanced Sky, Real Grass, Hand Painted Models), however while testing this issue I manually disabled all the graphical mods together, as well as individually. The issue still persists with vanilla textures/models/no post-processing. This small stutter occurs in every location in the game I've visited so far, dungeons, interiors, and outdoors.

It's not a major issue by any means, but I was wondering if there was anyone else encountering this issue, or if there was any potential idea about what could be causing it. It's almost as if several frames are just being skipped, yet I don't see any indication in the debug overlay or my performance monitor that anything is actually happening.

For reference
System Specs:
i7-8700K @ 4.3ghz
GTX 980ti
32gb RAM
Windows 10 64 bit

Ommamar
Posts: 339
Joined: Thu Jul 18, 2019 3:08 am

Re: Strange Stuttering even at locked 60fps

Post by Ommamar » Sun Aug 04, 2019 10:30 pm

I have noticed this type of performance on occasion it almost feels like the game is having to catch up to what is going on so it compensates by skipping frames it had not yet rendered. No idea what might be the cause but I have had it occur at random times.

Kane Tombs
Posts: 4
Joined: Sun Aug 04, 2019 11:07 pm

Re: Strange Stuttering even at locked 60fps

Post by Kane Tombs » Sun Aug 04, 2019 11:10 pm

I've had the same problem at 144 fps on a 144hz monitor and locked at 60.

User avatar
Interkarma
Posts: 4838
Joined: Sun Mar 22, 2015 1:51 am

Re: Strange Stuttering even at locked 60fps

Post by Interkarma » Sun Aug 04, 2019 11:56 pm

The streaming world needs to load data occasionally as you move around the world. We've made a lot of optimisations in the default game over the last few years to make this as seamless as possible, but there can still be skips/pauses depending on a few factors. The more mods are installed, the more work the streaming system has to do and the more likely game will stutter for a bit in certain places.

User avatar
King of Worms
Posts: 2194
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: Strange Stuttering even at locked 60fps

Post by King of Worms » Mon Aug 05, 2019 8:18 am

only stutter I have is when loading new chunk of the terrain. So I use terrain distance 2 instead of 4, that will do wonders in case u use Distant Terrain mod.

GreatSphynx
Posts: 10
Joined: Thu Aug 01, 2019 11:09 am

Re: Strange Stuttering even at locked 60fps

Post by GreatSphynx » Mon Aug 05, 2019 12:15 pm

Thanks Inter and King. I figured it was something related to streaming in assets. Again it's not a huge deal, I played a bunch today and streamed it for a while as well. Messed around with the retro renderer too, looks great. I really appreciate all the work you put in!

White Rhino PSO
Posts: 1
Joined: Fri Sep 20, 2019 12:13 am
Contact:

Re: Strange Stuttering even at locked 60fps

Post by White Rhino PSO » Fri Sep 20, 2019 12:35 am

I've recently gotten back into Daggerfall thanks to this Unity remake, and I've been noticing this same stuttering issue. I've been trying to pin down what might be causing it, but it seems like the best I can do is limit how badly and how often it happens.

For reference, I'm using the following mods: Birds in Daggerfall, Enhanced Sky, DREAM, Mountains and Hills, Villager Immersion, Handpainted Models, and Tedious Travel. I spent about an hour trying these mods in different combinations to test which of them (if any) might be the culprit, but none of them seem to have any effect on the stutter. Only one mod seemed to cause the game to stutter more often, and that was the Improved Lighting mod, which I now keep disabled. Even disabling every single mod I have didn't seem to make any noticeable effect.

So far, I've noticed a few things about the stuttering effect.

Firstly, it seems to happen more often when shadows are enabled, but completely disabling them doesn't totally remove the stutter.

Secondly, adjusting the graphical options doesn't seem to change whether or not it happens. Fastest or Beautiful quality, Terrain Distance at 2 or 4, even using 320 x 200 retro rendering mode doesn't seem to change anything.

Finally.. I've found a small section of Privateer's Hold where I can reliably recreate the stutter: the door leading into the room that contains the dungeon exit. Walking into or out of the room will cause the stutter. It even happens when I'm looking straight down at the floor, which makes me think that it's not related to graphical settings. But here's where things get really interesting:

Using console commands to make myself levitate, I pass through the doorway without touching the floor.. and there's no stutter.

I tested this further by floating my way all the way up the hallway and into the "torture chamber" room, the one that has the hidden room off to the side with a skeleton. Normally, the game will stutter at least once while walking up this hallway, and then it will sometimes stutter while moving toward the camp fire across the room. Sometimes it only happens when I start to side-step to the right while crossing the room. While levitating, there was no stutter at all.

I'm starting to think that the stutter is somehow caused by overlapping world geometry. I know that a lot of Elder Scrolls games were built by just slapping different dungeon segments together in new and interesting ways, but I'm not sure if any of that overlap translated to the Unity version of things.

User avatar
pango
Posts: 1417
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: Strange Stuttering even at locked 60fps

Post by pango » Fri Sep 20, 2019 5:43 am

I wouldn't have noticed it myself, but yes, it seems reproducible. Not sure if this is stuttering exactly, or sudden speed change for a single frame.
Could it be some motor issue ? Doesn't seem to be smooth follower reset or unstick handling though...
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
Interkarma
Posts: 4838
Joined: Sun Mar 22, 2015 1:51 am

Re: Strange Stuttering even at locked 60fps

Post by Interkarma » Fri Sep 20, 2019 11:13 pm

That does sound like unstick behaviour to me. Depending on alignment of approach, it's possible for this to trigger in doorways. I noticed this while building out the system, in any case.

I'm planning another pass at unstick eventually to handle this bug, and will try to solve this at the same time.

BansheeXYZ
Posts: 500
Joined: Fri Oct 23, 2015 8:19 pm

Re: Strange Stuttering even at locked 60fps

Post by BansheeXYZ » Sat Sep 21, 2019 8:44 am

Interkarma wrote:
Fri Sep 20, 2019 11:13 pm
I'm planning another pass at unstick eventually to handle this bug, and will try to solve this at the same time.
What if we let the player get stuck and then triggered the push forward when he used jump? Then it's not triggering passively when you don't want it to.

Post Reply