input lag

Post here if you need help getting started with Daggerfall Unity or just want to clarify a potential bug. Questions about playing or modding classic Daggerfall should be posted to Community.
Post Reply
Whip
Posts: 7
Joined: Thu Aug 01, 2019 10:48 pm

input lag

Post by Whip » Thu Aug 08, 2019 9:38 pm

I had an odd sound issue in a previous post and now I have an odd mouse lag issue. I'm not sure why I keep encountering these as I have a ton of PC games and run them without any issues but I do think this is something to do with my PC and not DFU but seeking help anyway...

I get terrible mouse lag and the fix was to disable v-sync. With that setting there is still a tiny bit of input lag but it's hardly noticeable and totally playable with Dream, Mountains and Hills, and Enhanced Sky. However if I change the filters to trilinear I will still get bad mouse lag. The fix is to go with the default filters (point, point, bilinear) but even then if I use the hand painted models mod the mouse lag kicks in yet again and I have no clue what the cause is. Does anyone have an idea as to what I can do to fix it.

Edit: I don't get mouse lag when viewing the DFU launch screen or when in any type of menu within the game (F6 for example), I only get while moving my character around.

User avatar
King of Worms
Posts: 2163
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: input lag

Post by King of Worms » Thu Aug 08, 2019 9:52 pm

I think u have mouse smoothing enabled in the game options.

That setting should be erased from the game, its atrocious

Ommamar
Posts: 330
Joined: Thu Jul 18, 2019 3:08 am

Re: input lag

Post by Ommamar » Thu Aug 08, 2019 10:12 pm

King of Worms wrote:
Thu Aug 08, 2019 9:52 pm
I think u have mouse smoothing enabled in the game options.

That setting should be erased from the game, its atrocious
What is that suppose to do anyway? I turned it off as things didn't work well with it on so probably a solution for Whip.

Whip
Posts: 7
Joined: Thu Aug 01, 2019 10:48 pm

Re: input lag

Post by Whip » Thu Aug 08, 2019 10:45 pm

Disabling mouse smoothing was actually the first thing I tried (I should have mentioned that in my post). However, after I posted this thread I was watching a video about this issue and someone mentioned windows scaling... I play on a gaming laptop but use windows scaling for browsing the web otherwise I have to squint to read... so I changed scaling to 100% AND also disabled mouse smoothing and that did the trick. The weird part is that after doing that I can then go back to my preferred scale and it still works without mouse lag. In fact it works fine now with vsync enabled too.

So, to play DFU I need to first change windows scale and then to get sound through the PC speakers I need to first activate bluetooth headphones and then after the game is running I can change the scale back and then disable BT headphones lol. My PC is so confused. But once again it's working so I'm happy and it's totally worth the this minor startup routine to play this epic game again.

I still can't get over the dedication that went into this project and not only to breath new life into the game, but to make it moddable as well. I get the feeling Daggerfall is about to get a big revival.

Post Reply