UseMipMapsInRetroMode setting

Post here if you need help getting started with Daggerfall Unity or just want to clarify a potential bug. Questions about playing or modding classic Daggerfall should be posted to Community.
Post Reply
GreatSphynx
Posts: 10
Joined: Thu Aug 01, 2019 11:09 am

UseMipMapsInRetroMode setting

Post by GreatSphynx » Sat Aug 10, 2019 12:48 am

I was digging through some of the other game files to see what kind of things can be tweaked.

I saw the UseMipMapsInRetroMode variable in DFTFU_Environment and wanted to test it out and set it to true. I've been experimenting using the DREAM environment textures with retro rendering mode and they can look pretty good. I wanted to see what the difference might be between enabling mipmaps or disabling them but it seems like every time the game starts it overwrites the value in the txt file to set it to false.
I set the file to read-only and still didn't notice a difference when viewing textures at extreme angles for example. Is this a feature that was just deprecated or disabled entirely? Or does it have to do with using an external texture pack?

User avatar
Interkarma
Posts: 4833
Joined: Sun Mar 22, 2015 1:51 am

Re: UseMipMapsInRetroMode setting

Post by Interkarma » Sat Aug 10, 2019 1:17 am

I don't experience the problem you mention of setting switching back to False. This stays as whatever I set it to once I change it and save the settings.ini file. I can't say what's happening there.

UseMipMapsInRetroMode only applies when retro rendering mode is set to 320x200 or 640x400. Otherwise this setting has no effect.

Even with mipmaps enabled in retro mode, there's a fairly high mip bias so that over short distances they aren't even obvious. You see it the most with windows as you approach buildings from a distance. The sampling frequency makes them blurry or degrade into moire patterns.

Recommend simply leaving this one disabled. I can't see a clear benefit to enabling mipmaps at such low resolutions, and mainly left it in for testing.

Post Reply