4:3 Retro sometimes doesn't wanna work.

Post here if you need help getting started with Daggerfall Unity or just want to clarify a potential bug. Questions about playing or modding classic Daggerfall should be posted to Community.
Post Reply
Max_CSD
Posts: 1
Joined: Mon Jul 05, 2021 6:25 pm

4:3 Retro sometimes doesn't wanna work.

Post by Max_CSD »

Hello every one! The issue is I prefer to play 4:3 retro style with black bars but sometimes during the game my screen stretches out after a loading and it becomes ugly and loses these nice looking retro lines. How do I treat the issue? Cz u won't believe me how much I love retro rendering with those 199x anime looking black bars. Help me please any answer would be well appreciated!

User avatar
pango
Posts: 3048
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: 4:3 Retro sometimes doesn't wanna work.

Post by pango »

Welcome to the forums, Max_CSD!

Check out the "gold" and "silver" retro settings:
viewtopic.php?f=4&t=1743

By the way it currently only works under Windows, as it relies on Unity to implemented the fixed aspect ratio, and Unity currently does not implement that on all platforms...
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

haloterm
Posts: 318
Joined: Sat Feb 16, 2019 5:21 am

Re: 4:3 Retro sometimes doesn't wanna work.

Post by haloterm »

pango wrote: Thu Sep 16, 2021 6:42 am By the way it currently only works under Windows, as it relies on Unity to implemented the fixed aspect ratio, and Unity currently does not implement that on all platforms...
Oh interesting, that explains why I could not use that properly on my old secondary Linux notebook, a ThinkPad T420. There it stretches 4:3 to wide-screen. On that device I help myself with setting a 4:3 screen resolution in the OS prior to starting DFU.

Post Reply