(0.13.1) - Ocassional crash on ALT+TAB

Post here if you need help getting started with Daggerfall Unity or just want to clarify a potential bug. Questions about playing or modding classic Daggerfall should be posted to Community.
Post Reply
User avatar
King of Worms
Posts: 4294
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

(0.13.1) - Ocassional crash on ALT+TAB

Post by King of Worms »

I ALT+TAB out of the game to other programs a lot and Ive noticed 0.13.1 tends to crash when I do so.

Id say 1 of 4 attempts do crash. Game seems stable otherwise. It might be some out-of-date mod Im using, but the fact the game crashes only on ALT+TAB is strange.

Heres the log after such a crash:
Player.rar
(11.11 KiB) Downloaded 11 times

User avatar
Interkarma
Posts: 6578
Joined: Sun Mar 22, 2015 1:51 am

Re: (0.13.1) - Ocassional crash on ALT+TAB

Post by Interkarma »

Code: Select all

DFTFU 1.9.0: ExclusiveFullscreen | True 
One option is to set ExclusiveFullscreen back to False. As a general issue, switching display modes can trigger problems, whether these are in the game itself, engine runtime, or GPU driver. A lot has to happen when changing resolutions and dumping stuff in and out of graphics memory. When ExclusiveFullscreen is disabled, the game runs at desktop display mode always, so less is happening when alt+tabbing and there's less chance of triggering a problem somewhere in the stack.

I recall a previous conversation of ours when exclusive fullscreen came up, and you probably have this enabled based on that. But if it didn't actually solve the issue in that post, or that problem is less of an issue than the crashing, best to just keep ExclusiveFullscreen set to false.

For myself, I prefer exclusive fullscreen disabled in every game that supports it. Thrashing around between display modes with alt+tab seems to cause problems more often than not. It's also much faster to switch back-and-forth with desktop during development, which I do a lot.

Code: Select all

DFTFU 1.9.0: RunInBackground | True
Second option is to try setting RunInBackground to False. This setting suspends Unity runtime when game loses focus, and could help mitigate whatever is happening when switching between display modes.

User avatar
King of Worms
Posts: 4294
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: (0.13.1) - Ocassional crash on ALT+TAB

Post by King of Worms »

Thank you, Ive disabled exclusive fullscreen and will report back if I still get crashes.
I might actually try the 2nd option as well, if I get crashes and only THAN report back.

User avatar
King of Worms
Posts: 4294
Joined: Mon Oct 17, 2016 11:18 pm
Location: Scourg Barrow (CZ)
Contact:

Re: (0.13.1) - Ocassional crash on ALT+TAB

Post by King of Worms »

After some testing, Im quite sure the Exclusive fullscreen was the case and switching is back fixed the issue. No more crashes.

Post Reply