Village buildings not visible when arriving without fast travel

Discuss Daggerfall Unity and Daggerfall Tools for Unity.
haloterm
Posts: 100
Joined: Sat Feb 16, 2019 5:21 am

Village buildings not visible when arriving without fast travel

Post by haloterm » Sat Feb 08, 2020 8:28 pm

I am not sure if this is related to using the Distant Terrain Mod or a bug, just want to ask:

Has anybody had the problem that you walk on foot from one village to another and, when you arrive at your target, you get the "you are entering ..." message and see the roads of the village, but every building is missing? Making a fast travel then shows the building correctly.

Have seen this today while I was hiking a bit around Daggerfall City. I went from Ripwych Commons (the village that is northwest of Daggerfall) in southeastern direction until I reached the hills in the north of Daggerfall City. I then basically followed Daggerfall's city wall, on top of the hills, going west to east, having a great view on the city, the castle and the Iliac Bay in the background. Beautiful, really. After I passed the northeastern corner of the city, I turned south, went for a while, then turned southwest, to finally reach Copperfield Manor. And then the bug above happend.

I intend to test this again with Distant Terrain disabled and Mountains & Hills as alternative, and also with no terrain mod at all (altough that will be a very boing trip due to the missing landscape variations). But still wanna know if others know this problem?

(By the way, the distance I set in the Daggerfall Unity settings is 2, because this is usally enough for far viewing distances in the Distant Terrain mod and better for performance.)


Edit: Two observations:

1. Did not happen with Mountains & Hills

2. Did not happen again with Distant Terrain mod when I set distance setting in DFU to 3. Will keep it that way...

User avatar
pango
Posts: 2049
Joined: Wed Jul 18, 2018 6:14 pm
Location: France
Contact:

Re: Village buildings not visible when arriving without fast travel

Post by pango » Sat Feb 08, 2020 9:45 pm

That the kind of bug you think has been eradicated, but keeps coming back...
When a measure becomes a target, it ceases to be a good measure.
-- Charles Goodhart

User avatar
JorisVanEijden
Posts: 89
Joined: Mon Aug 12, 2019 5:02 pm

Re: Village buildings not visible when arriving without fast travel

Post by JorisVanEijden » Sun Feb 09, 2020 7:38 am

Here's another recent example: viewtopic.php?f=5&t=3368 (middle picture)

haloterm
Posts: 100
Joined: Sat Feb 16, 2019 5:21 am

Re: Village buildings not visible when arriving without fast travel

Post by haloterm » Sun Feb 09, 2020 8:04 am

pango wrote:
Sat Feb 08, 2020 9:45 pm
That the kind of bug you think has been eradicated, but keeps coming back...
Ah, I see! Thanks for confirming.

User avatar
dani26795
Posts: 19
Joined: Sat Jan 25, 2020 3:51 am
Location: Spain

Re: Village buildings not visible when arriving without fast travel

Post by dani26795 » Sun Feb 09, 2020 12:21 pm

Ah yes, this happened me once on 0.10.17 when I reached a dungeon location without fast travelling. Saving and reloading made the typical lake and entrance mound spawn properly.

Ommamar
Posts: 502
Joined: Thu Jul 18, 2019 3:08 am

Re: Village buildings not visible when arriving without fast travel

Post by Ommamar » Mon Feb 10, 2020 12:41 am

It might of been around a long time, having to do with how both classic and DFU load in cells. I know I only recently played a character with the idea of I will just travel physically from place to place. Traditionally I would use fast travel to get around so it wouldn't be noticeable for this to be happening. With the mods allowed in DFU it becomes a lot more feasible to travel with using the fast travel option. I do recall hearing about this probably at least 5 build backs, the fix was adjusting the load sequence of mods. No idea if this would solve it for the current build or not but would be a good place to start.

User avatar
Hazelnut
Posts: 1995
Joined: Sat Aug 26, 2017 2:46 pm
Contact:

Re: Village buildings not visible when arriving without fast travel

Post by Hazelnut » Tue Feb 11, 2020 7:57 pm

I guess we need to ascertain 2 things: 1) does this ever occur without mods?, 2) what mods & ordering enables it?
See my mod code for examples of how to change various aspects of DFU: https://github.com/ajrb/dfunity-mods

User avatar
Helegad
Posts: 141
Joined: Sun Oct 07, 2018 6:24 am

Re: Village buildings not visible when arriving without fast travel

Post by Helegad » Wed Feb 12, 2020 2:00 am

Ommamar wrote:
Mon Feb 10, 2020 12:41 am
might of
Image

User avatar
Jay_H
Posts: 3135
Joined: Tue Aug 25, 2015 1:54 am

Re: Village buildings not visible when arriving without fast travel

Post by Jay_H » Wed Feb 12, 2020 2:49 am

Helegad, if we're going to point out minor grammatical errors here, this place is going to fall apart quickly. It's not helping anyone.

I agree with Hazelnut's point: I don't recall this ever occurring without mods. I know we previously pointed to DREAM - Sound and its method of loading into the game; we'll have to find a common denominator. haloterm, if you can show the mod loadout you used when this occurred, that'd be a big help.
Come join Lysandus' Tomb, a Daggerfall Unity fan Discord.
See the Daggerfall Unity Wiki on the UESP.

User avatar
Helegad
Posts: 141
Joined: Sun Oct 07, 2018 6:24 am

Re: Village buildings not visible when arriving without fast travel

Post by Helegad » Wed Feb 12, 2020 4:26 am

My bad, I meant it in humour. :mrgreen:

Post Reply