Mouse in win10

Just need help getting up and running or have a general support question? This is the place.
Post Reply
malcur
Posts: 5
Joined: Sat Jul 28, 2018 1:39 pm

Mouse in win10

Post by malcur » Sat Jul 28, 2018 1:59 pm

Probably solution to my problem is very simple but I just can't find it...
I'm using Daggerfall setup and Unity #122. Unity finds a Arena2 folder and I press play and I find myself in dungeon.
No mater how i change key bindings I can't turn - just forth and back, mouse look doesn't work, return key do nothing and in configuration menu mouse tab is red...
Please help!

User avatar
Interkarma
Posts: 3036
Joined: Sun Mar 22, 2015 1:51 am

Re: Mouse in win10

Post by Interkarma » Sat Jul 28, 2018 9:28 pm

Welcome to the forums :)

It sounds like the mouse might not be getting captured properly in game. Do you see the cursor kind of floating around in game while you're trying to mouse-look? Does clicking into the game lock the cursor (it should disappear once locked and show only when UI is open).

The in game mouse settings window isn't currently implemented, you can instead change these settings in the startup UI (mouse sensitivity, invert mouse).

malcur
Posts: 5
Joined: Sat Jul 28, 2018 1:39 pm

Re: Mouse in win10

Post by malcur » Sun Jul 29, 2018 9:37 am

No - I just have a non-moving cross hair in the screen center. The only visible mouse activity is during attack.

I use wireless Logitech mouse and t tried with old one on cable too - no difference.

User avatar
Interkarma
Posts: 3036
Joined: Sun Mar 22, 2015 1:51 am

Re: Mouse in win10

Post by Interkarma » Sun Jul 29, 2018 10:52 am

Thank you, sounds like mouse is captured OK. Something else is going wrong then.

Could you please zip up a copy of your "output_log.txt" and attach here for me to review? You'll find the output log in your persistent data path, which is shown when starting the game. Check the linked topic below for more information on finding the player log.

https://forums.dfworkshop.net/viewtopic.php?f=24&t=313

Cheers!

malcur
Posts: 5
Joined: Sat Jul 28, 2018 1:39 pm

Re: Mouse in win10

Post by malcur » Sun Jul 29, 2018 5:01 pm

There it is.
I noticed that this file is wrote in VR folder by Commodo internet security. Maybe I should repeat installation with Commodo switched off?
Attachments
output_log.zip
(4.23 KiB) Downloaded 3 times

User avatar
Interkarma
Posts: 3036
Joined: Sun Mar 22, 2015 1:51 am

Re: Mouse in win10

Post by Interkarma » Sun Jul 29, 2018 9:59 pm

Ah, it sounds like the game is being sandboxed by Comodo. It's possible this is having a negative interaction with Unity's input system. After searching around, I was able to find others mentioning similar problems with Comodo and Unity input. Here's a Steam user thread for input issues with The Long Dark where Comodo was related (starting from post #6)

https://steamcommunity.com/app/305620/d ... 169896922/

It might be necessary to disable auto-sandboxing for Daggerfall Unity's executable. Here's a Comodo KB article to help with this if needed. I'd never recommend disabling your AV completely, just excluding the sandboxing for DFUnity should do it in this case.

https://help.comodo.com/topic-72-1-623-7666-.html

Good luck!

User avatar
Feralwarlord
Posts: 72
Joined: Sat Jul 29, 2017 10:08 am

Re: Mouse in win10

Post by Feralwarlord » Mon Jul 30, 2018 4:52 am

With comodo check if the DF Unity appears under unblock application if it does remove it and it should work
Comodo.PNG
Comodo.PNG (174.27 KiB) Viewed 180 times

malcur
Posts: 5
Joined: Sat Jul 28, 2018 1:39 pm

Re: Mouse in win10

Post by malcur » Mon Jul 30, 2018 5:38 am

Thank you guys very much! Now I see a chance to fix the problem. After work I will check my commodo and let you know how it goes.

malcur
Posts: 5
Joined: Sat Jul 28, 2018 1:39 pm

Re: Mouse in win10

Post by malcur » Mon Jul 30, 2018 5:31 pm

I made changes in commodo and now Unity works like charm!
Thank you all for help I'm really very grateful.

Post Reply