Page 1 of 1

Black Screen When Loading Saves In Buildings Only

Posted: Sun Jun 04, 2023 12:25 am
by Ravenwind286
Good evening. I am encountering an issue upon loading save games when inside buildings where the screen is black except for the UI. This only happens when loading saves while the game is already running and not when loading from the main menu. I have read previous topics on this issue and tried the solutions posted there but haven't had any success in remedying this issue. I'm running the game on Windows 10 Pro, 64bit, Version 22H2.

I encountered this issue while playing the Windows 64bit v0.14.5 Beta but also tested with the Windows 64bit v.0.15.2 Beta and it still occurred with that version as well. A few of the buildings I have tested this in were the Mages Guild, Fighters Guild, and a few general stores, all with the same result.

I am running mods. The save I am currently having issues with I created today. Saving and loading were fine at first, but the issue seems to appear over time. I do use quick saves a lot, but I am not sure if that would be a part of the problem or not.

I tried narrowing things down to see if it was an issue with a particular mod. I created a fresh save without any mods enabled and the problem did not occur. I progressively loaded all of my mods on to that save but was unable to reproduce the issue I was having with my previous save. This is why it seems that the issue happens after playing for a while.

Some of the previously posted solutions I tried were to disable the alternative music, delete the settings.ini and also deleting ConversationData. None of these seemed to help, unfortunately.

I have attached a screenshot as well as a copy of my save game. Please let me know if you need any more information and thank you in advance for your help.

Re: Black Screen When Loading Saves In Buildings Only

Posted: Sun Jun 04, 2023 12:35 am
by Ravenwind286
I almost forgot to mention, I also deleted and set up again using the DaggerfallGameFiles method.

Re: Black Screen When Loading Saves In Buildings Only

Posted: Sun Jun 04, 2023 1:35 am
by Ravenwind286
I may have found the source of my issue, as I did some further testing turning mods off one at a time. Once I disabled Improved Interior Lighting V1.0.5 my saves are loading properly once again.

I also checked out the Nexus Mods page for Improved Interior Lighting
( ... ?tab=posts) and one of the posts there says that it may be a conflict with the Transparent Windows mod when it is raining in the game that causes the issue I had.

Re: Black Screen When Loading Saves In Buildings Only

Posted: Sun Jun 04, 2023 5:58 am
by Jay_H
Excellent! Good work finding the problem :) You'll have to take up the issue with the mod creators of the one or the other, to get a full resolution on this.

Re: Black Screen When Loading Saves In Buildings Only

Posted: Fri Jun 09, 2023 8:43 am
by thenameisthegame
I remember encountering the problem, and found a workaround which, I don't know if it could work for you since I might have a different mod order or loadout, but I'll post it here for you to try!

If using both Ambient Weather and Transparent Windows, better to UNCHECK the Rain SFX in Transparent Windows settings to avoid conflicts.

While Improved Interior Lighting would throw an exception in the log, it wouldn't prevent anything from happening good or bad if using those other mods too, but to avoid the black screen problem from happening, unchecking Rain SFX allows for the use of all the mods without disabling them entirely! It's a workaround, didn't see any problem since and I'm still using all 3 mods.

Essentially, I used Ambient Weather as a means to have rain sounds inside still, along with thunder! I later even pushed things further by installing Better Ambience for even more Rain sounds in addition of the other mod to see if things would break, but nope! All work!